jQuery 2.X系をIE8以下にも考慮して使用する方法


現在(2014/04/17時点)で、jQueryのバージョンは2.1です。

jQueryは2.X系からIE8以前のブラウザのサポート中止し、高速化・軽量化をが実現されました。

とはいえ、制作現場だとIE8以下も考慮しないといけない時がほとんどです。

大体、僕はIE8以降までサポートすることが多いですね。

そこで、IE8以降は jQuery 1.X系。それ以外のブラウザではjQuery 2.X系を使用する時は以下のようにして読み込みます。

参考元はjQueryのオフィシャルページです。

早く、IE8も切り捨てる時代が来ないですかね。

XPのサポートも終了したし、そう遠くないかも?

この記事を書いた人:

ナカシマ

北区赤羽在住のWEBデザイナー兼エンジニア。インターネット、WordPress、本・漫画、音楽が大好き。妻と猫と暮らすアップル信者。

BLOG: 着ぐるみ追い剥ぎペンギン